Roblox Mobile System Requirements

Follow

Roblox Mobile currently works on the following mobile devices:

  • Apple iOS: Roblox Mobile supports iPad 2+, iPhone 4s+ and iPod touch 5th Generation. iOS 8 or greater is required.
  • Android: Roblox Mobile supports many devices running Android 4.0.3 and newer. These devices must also have an ARMv7 processor and should not be running the Tegra 2 chipset.
  • Amazon Fire OS: Roblox Mobile currently supports Kindle Fire HDX 7 (3rd Gen), Kindle Fire HDX 8.9 (3rd Gen), Fire HDX 8.9 (4th Gen), Fire HD 6 & 7 (4th Gen), Fire HD 8 & 10 (5th Gen), and Fire (5th Gen)   except: Amazon Fire HD 2013

Note: Newly released operating systems/devices or pre-released versions of operating systems/devices may not immediately be supported.

Internet Requirements

Roblox requires a minimum of a 4-8 Mb/s internet connection. If you experience problems and are currently connected to your phone company's 3G or 4G network, please try connecting through WIFI instead for a faster and more stable connection.

Android Warning Screens

Due to the very large number of Android devices in existence, we cannot be certain that all devices will run optimally even if they are running the correct version of the operating system and do not have a Tegra 2 chipset.
 
We have 2 levels of unsupported Android devices - skippable and unskippable:
  • Skippable Devices: These types of devices will get a warning telling you that your device may not be powerful enough to play games smoothly. This is just a warning to let you know that while your device isn't specifically supported, games might still run though they will likely lag a little (or a lot). Tapping outside the warning box will make it go away and the game should keep loading. 
  • Unskippable Devices: will get a message that informs you that your device doesn't meet the minimum system requirements. This means the device is not able to play games on Roblox. This message usually shows up on devices that use the Tegra 2 graphics chipset or a processor other than an ARMv7. These kinds of tablets/phones do not support features that the Roblox needs to be able to function. However, users with these unskippable messages will still be able to access all other parts of the app outside of games.

More Information

For more information on other mobile related matters, please see the following links: